IPRO Cloud Canada - Partial Outage
Incident Report for IPRO
Resolved
This incident has been resolved.
Posted Oct 16, 2021 - 13:31 MST
Investigating
We are currently investigating an issue affecting some users ability to view and download documents in IPRO review.
Posted Oct 16, 2021 - 12:42 MST
This incident affected: IPRO Services Environment - Canada.