Cloud Portal Application Access
Incident Report for IPRO
Resolved
The issues connecting to Ipro applications upon login through the Ipro Cloud Portal have now been resolved.
Posted Jun 12, 2021 - 13:47 MST
Investigating
We are currently investigating issues connecting to Ipro applications upon login through the Ipro Cloud Portal.
Posted Jun 12, 2021 - 12:41 MST
This incident affected: IPRO Cloud Login Portal.