IPRO Technical Support Phone System Outage
Incident Report for IPRO
Resolved
Thank you for your patience. This incident has been resolved, the phone systems are fully operational.
Posted May 25, 2021 - 16:03 MST
Investigating
We are currently investigating this issue, at this time Technical Support is unable to be reached by phone. We apologize about this inconvenience, if you need support please contact support@iprotech.com.
Posted May 25, 2021 - 13:57 MST
This incident affected: Phone Systems: (Ipro Phone System).