Ipro Cloud - Partial outage
Incident Report for IPRO
Resolved
This incident has been resolved.
Posted Aug 17, 2021 - 20:15 MST
Investigating
We are currently investigating an issue affecting some users ability to connect to the Ipro Cloud environment including access to Ipro Review and Administration.
Posted Aug 17, 2021 - 19:08 MST
This incident affected: Ipro Cloud.