Ipro Cloud Portal - Outage
Incident Report for IPRO
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 07:55 MST
Investigating
We are currently investigating an issue affecting the ability to connect to the IPRO Cloud Portal. Access to Ipro Review through the web it still working as expected.
Posted Apr 07, 2021 - 07:28 MST
This incident affected: Ipro Cloud Login Portal.